LKW32 - história vývinu

Program LKW vznikol ešte pre DOS ako DOS-ovská aplikácia. Potreboval som ho vtedy pre seba a ešte pre iného užívateľa. Pozdejšia verzia napísaná vo Visual Basicu 3 mala nevýhodu v tom, že vyžadovala runtime modul Visual Basicu.

Táto verzia vytvorená v jazyku RapidQ je plne 32-bitová a bola odskúšaná vo WINDOWS98, WINDOWS NT a WINDOWS 2000.

Pre svoj beh nepotrebuje LKW32 nijaké iné súbory okrem štandartných .DLL z WINDOWS.

Copyright 1997-2001 by Branislav Štofko Bratislava
All Rights reserved


Kód Kamenický

Na začiatku éry PC u nás navrhli dvaja bratia také kódy pre českú a slovenskú diakritiku, že ak sa text prezeral bežným programom MS DOSu, bol s obmedzením čitateľný.

Tento kód nazývaný podľa bratov Kamenických sa používal po dlhé roky. Existovali dokonca tlačiarne, kde bolo toto kódovanie zabudované, tlačiareň sa dala prepnúť na tento kód. Ostatné tlačiarne museli tlačiť diakritiku v grafickom režime, tak ako teraz vo WINDOWS, čo bolo pomalšie.

Kód Kamenický podporoval textový editor T602 pre tlač a na obrazovke. Tam sa nazýval KEYBCS2.

Pre zobrazenie kódu na obrazovke mimo editora T602 bolo potrebné do pamäti VGA karty naládovať uživateľom definovaný font.


Kód Latin 2

Po roku 1989 sa viac otvorila možnost vplyvu firmy IBM, ktorá sa u nás rozhodla presadzovať pre diakritiku kód 852 s názvom Latin 2.

Tento kód je nekompatibilný s kódom Kamenický a priniesol ďalšie komplikácie. To však už bolo už v čase, keď nastupovali staré WINDOWS 3.1

Kód Latin 2 podporoval textový editor T602 pre tlač a na obrazovke. Tam sa nazýval Latin2.

Pre zobrazenie kódu na obrazovke mimo editora T602 bolo potrebné do pamäti VGA karty naládovať uživateľom definovaný font.


Kód Windows 1250

S nástupom Windows nastal čas kódu 1250 a s tým spojené prekódovanie starých súborov.

Tento kód je nekompatibilný s kódom Kamenický a čiastočne aj Latin2.

Kód 1250 nebol nikdy podporovaný textovým editorom T602.


Kód ISO-8859-2

Pretože okrem Windows existuje aj LINUX je vhodné pre internetové stránky používať univerzálny kód a tým je ISO-8859-2. Pozor existuje aj ISO-8859-1 , to je ovšem niečo iné.

Tento kód je nekompatibilný s kódom Kamenický a Latin2. Len čiastočne sa prekrýva s kódom Windows 1250.

Kód ISO-8859-2 nebol nikdy podporovaný textovým editorom T602.


Použitie programu

Nastavte si vstupný kód nasledovne :

Nastavte si výstupný kód nasledovne :

Odštartujte konverziu zvoleného súboru :